$re = '/^(\/[\w-]+)+(\.[\w-]+)+$/mi';
$str = '/root.file
/nested/file.ext
/allows-hyphen/file-hyphen.md5
/allows_underscore/file_underscore.xxx
/wont_match
/wont_match.
/wont_match/wont_match.
/wont_match_double_slashes//asasa/xxx.aaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);