package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Process[123]A`)
var str = `Process1A
Process2A
Process3A
Process0A
Process4A
Process1000A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}