re = /Process[123]A/m
str = 'Process1A
Process2A
Process3A
Process0A
Process4A
Process1000A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end