$re = '/Process[123]A/m';
$str = 'Process1A
Process2A
Process3A
Process0A
Process4A
Process1000A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);