#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(- ?)(?!.*@(?:done|things)).*$"
Local $sString = "title" & @CRLF & _
" - hi" & @CRLF & _
" - I am @done" & @CRLF & _
" - Added to @things" & @CRLF & _
" - Test is @done" & @CRLF & _
"a note" & @CRLF & _
"another note" & @CRLF & _
"- Then a task" & @CRLF & _
"- another task @done"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")