$re = '/(- ?)(?!.*@(?:done|things)).*$/m';
$str = 'title
- hi
- I am @done
- Added to @things
- Test is @done
a note
another note
- Then a task
- another task @done';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);