re = /(- ?)(?!.*@(?:done|things)).*$/m
str = 'title
- hi
- I am @done
- Added to @things
- Test is @done
a note
another note
- Then a task
- another task @done'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end