using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(- ?)(?!.*@(?:done|things)).*$";
string input = @"title
- hi
- I am @done
- Added to @things
- Test is @done
a note
another note
- Then a task
- another task @done";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}