package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bIMIS\/C\/\d+\/\d+\/\d+\/\d+\/\d+\b`)
var str = `Being Settlement of school fee, student Number IMIS/C/28727/14/7/2022/28980 in respect of Tony Alex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}