re = /\bIMIS\/C\/\d+\/\d+\/\d+\/\d+\/\d+\b/m
str = 'Being Settlement of school fee, student Number IMIS/C/28727/14/7/2022/28980 in respect of Tony Alex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end