$re = '/\bIMIS\/C\/\d+\/\d+\/\d+\/\d+\/\d+\b/m';
$str = 'Being Settlement of school fee, student Number IMIS/C/28727/14/7/2022/28980 in respect of Tony Alex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);