using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"республика\s*([\s\S]*?)\s*край\s*\(\s*область\s*\)\s*([^\n]*?)\s*\nрайон\s*([^\n]*?)\s*\nнас\.\s*пункт\s*([^\n]*?)\s*\n";
string input = @"Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край( область ) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ
РеспубликаХХХХХХХ
ХХХХХ
ХХХХХ
Край(область)ХХХХХХ
РайонХХХХХХХХ
Нас.пунктХХХХХХХХХ
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}