use strict;
my $str = 'Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край( область ) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ
РеспубликаХХХХХХХ
ХХХХХ
ХХХХХ
Край(область)ХХХХХХ
РайонХХХХХХХХ
Нас.пунктХХХХХХХХХ
';
my $regex = qr/республика\s*([\s\S]*?)\s*край\s*\(\s*область\s*\)\s*([^\n]*?)\s*\nрайон\s*([^\n]*?)\s*\nнас\.\s*пункт\s*([^\n]*?)\s*\n/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}