$re = '/республика\s*([\s\S]*?)\s*край\s*\(\s*область\s*\)\s*([^\n]*?)\s*\nрайон\s*([^\n]*?)\s*\nнас\.\s*пункт\s*([^\n]*?)\s*\n/iu';
$str = 'Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край( область ) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ
РеспубликаХХХХХХХ
ХХХХХ
ХХХХХ
Край(область)ХХХХХХ
РайонХХХХХХХХ
Нас.пунктХХХХХХХХХ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);