import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "республика\\s*([\\s\\S]*?)\\s*край\\s*\\(\\s*область\\s*\\)\\s*([^\\n]*?)\\s*\\nрайон\\s*([^\\n]*?)\\s*\\nнас\\.\\s*пункт\\s*([^\\n]*?)\\s*\\n";
final String string = "Республика ХХХХХХХ\n"
+ "ХХХХХ \n"
+ "ХХХХХ \n"
+ "Край( область ) ХХХХХХ \n"
+ "Район ХХХХХХХХ \n"
+ "Нас.пункт ХХХХХХХХХ \n"
+ "РеспубликаХХХХХХХ\n"
+ "ХХХХХ\n"
+ "ХХХХХ\n"
+ "Край(область)ХХХХХХ\n"
+ "РайонХХХХХХХХ\n"
+ "Нас.пунктХХХХХХХХХ\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}