#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([CM])\s*-\s*(\d)\s*-\s*(\d)|(T)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*(\d)|(A)\s*-\s*(.*?)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*([NSEO])\s*-\s*([AGD]*)"
Local $sString = "C - 3 - 4" & @CRLF & _
"M - 1 - 0" & @CRLF & _
"M - 2 - 1" & @CRLF & _
"T - 0 - 3 - 2" & @CRLF & _
"T - 1 - 3 - 3" & @CRLF & _
"A - Lara - 1 - 1 - S - AADADAGGA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")