use strict;
my $str = 'C - 3 - 4
M - 1 - 0
M - 2 - 1
T - 0 - 3 - 2
T - 1 - 3 - 3
A - Lara - 1 - 1 - S - AADADAGGA';
my $regex = qr/([CM])\s*-\s*(\d)\s*-\s*(\d)|(T)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*(\d)|(A)\s*-\s*(.*?)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*([NSEO])\s*-\s*([AGD]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}