using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"([CM])\s*-\s*(\d)\s*-\s*(\d)|(T)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*(\d)|(A)\s*-\s*(.*?)\s*-\s*(\d)\s*-\s*(\d)\s*-\s*([NSEO])\s*-\s*([AGD]*)";
        string input = @"C - 3 - 4
M - 1 - 0
M - 2 - 1
T - 0 - 3 - 2
T - 1 - 3 - 3
A - Lara - 1 - 1 - S - AADADAGGA";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}