const regex = new RegExp('([CM])\\s*-\\s*(\\d)\\s*-\\s*(\\d)|(T)\\s*-\\s*(\\d)\\s*-\\s*(\\d)\\s*-\\s*(\\d)|(A)\\s*-\\s*(.*?)\\s*-\\s*(\\d)\\s*-\\s*(\\d)\\s*-\\s*([NSEO])\\s*-\\s*([AGD]*)', 'gm')
const str = `C - 3 - 4
M - 1 - 0
M - 2 - 1
T - 0 - 3 - 2
T - 1 - 3 - 3
A - Lara - 1 - 1 - S - AADADAGGA`;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}