#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)wico-2(([ ,:-]+|$).*$)"
Local $sString = "WiCO-2 example " & @CRLF & _
"WiCO-2-dosomething" & @CRLF & _
"WICO-29" & @CRLF & _
"WICO-9" & @CRLF & _
"wiCO-2, great" & @CRLF & _
"wiCo-2: description"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")