$re = '/wico-2(([ ,:-]+|$).*$)/im';
$str = 'WiCO-2 example
WiCO-2-dosomething
WICO-29
WICO-9
wiCO-2, great
wiCo-2: description';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);