const regex = /wico-2(([ ,:-]+|$).*$)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('wico-2(([ ,:-]+|$).*$)', 'img')
const str = `WiCO-2 example
WiCO-2-dosomething
WICO-29
WICO-9
wiCO-2, great
wiCo-2: description`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}