using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"wico-2(([ ,:-]+|$).*$)";
string input = @"WiCO-2 example
WiCO-2-dosomething
WICO-29
WICO-9
wiCO-2, great
wiCo-2: description";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}