#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\\(?:xn|[brw])([\s\S]+?)\r?\n"
Local $sString = "\xn[Lan]Allez, il faut se dépécher, RED !" & @CRLF & _
"\xn[Lan]Allez, il faut se dépécher, RED !" & @CRLF & _
"\bI'll stay here, then" & @CRLF & _
"\rFirst, you should restore your Pokémon to full health." & @CRLF & _
"\rFirst, you should restore your Pokémon to full health." & @CRLF & _
"\w[signskin]Once you save your game, you can access the Mystery Gift." & @CRLF & _
"\w[signskin]Once you save your game, you can access the Mystery Gift." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")