re = /\\(?:xn|[brw])([\s\S]+?)\r?\n/
str = '\\xn[Lan]Allez, il faut se dépécher, RED !
\\xn[Lan]Allez, il faut se dépécher, RED !
\\bI\'ll stay here, then
\\rFirst, you should restore your Pokémon to full health.
\\rFirst, you should restore your Pokémon to full health.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end