import Foundation
let pattern = #"\\(?:xn|[brw])([\s\S]+?)\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\xn[Lan]Allez, il faut se dépécher, RED !
\xn[Lan]Allez, il faut se dépécher, RED !
\bI'll stay here, then
\rFirst, you should restore your Pokémon to full health.
\rFirst, you should restore your Pokémon to full health.
\w[signskin]Once you save your game, you can access the Mystery Gift.
\w[signskin]Once you save your game, you can access the Mystery Gift.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)