using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(?:xn|[brw])([\s\S]+?)\r?\n";
string input = @"\xn[Lan]Allez, il faut se dépécher, RED !
\xn[Lan]Allez, il faut se dépécher, RED !
\bI'll stay here, then
\rFirst, you should restore your Pokémon to full health.
\rFirst, you should restore your Pokémon to full health.
\w[signskin]Once you save your game, you can access the Mystery Gift.
\w[signskin]Once you save your game, you can access the Mystery Gift.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}