#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<(?<url>[^>]*)>(?:[ \t]*;[ \t]*[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+[ \t]*(?:=[ \t]*(?:[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22))?)*[ \t]*;[ \t]*rel[ \t]*=[ \t]*(?<rel>[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22)[ \t]*(?:[,;]|$)"
Local $sString = "</test/11/webmention>;me; rel="webmention"; pa=wow" & @CRLF & _
"</test/11/webmention>;me; rel=webmention; pa=wow" & @CRLF & _
"</test/11/webmention>;me; rel="webmention and more"; pa=wow" & @CRLF & _
"</test/11/webmention>;me; rel=webmention, </test/11/webmention>;me; rel=webmention;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")