import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<(?<url>[^>]*)>(?:[ \\t]*;[ \\t]*[\\x21\\x23-\\x27\\x2A\\x2B\\x2D\\x2E\\x5E-\\x60\\x7C\\x7E\\x30-\\x39\\x41-\\x5A\\x61-\\x7A]+[ \\t]*(?:=[ \\t]*(?:[\\x21\\x23-\\x27\\x2A\\x2B\\x2D\\x2E\\x5E-\\x60\\x7C\\x7E\\x30-\\x39\\x41-\\x5A\\x61-\\x7A]+|\\x22(?:[\\x09\\x20\\x21\\x23-\\x5B\\x5D-\\x7E\\x80-\\xFF]|\\x5C[\\x09\\x20\\x21-\\x7E\\x80-\\xFF])*\\x22))?)*[ \\t]*;[ \\t]*rel[ \\t]*=[ \\t]*(?<rel>[\\x21\\x23-\\x27\\x2A\\x2B\\x2D\\x2E\\x5E-\\x60\\x7C\\x7E\\x30-\\x39\\x41-\\x5A\\x61-\\x7A]+|\\x22(?:[\\x09\\x20\\x21\\x23-\\x5B\\x5D-\\x7E\\x80-\\xFF]|\\x5C[\\x09\\x20\\x21-\\x7E\\x80-\\xFF])*\\x22)[ \\t]*(?:[,;]|$)";
final String string = "</test/11/webmention>;me; rel=\"webmention\"; pa=wow\n"
+ "</test/11/webmention>;me; rel=webmention; pa=wow\n"
+ "</test/11/webmention>;me; rel=\"webmention and more\"; pa=wow\n"
+ "</test/11/webmention>;me; rel=webmention, </test/11/webmention>;me; rel=webmention;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}