# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^<(?<url>[^>]*)>(?:[ \t]*;[ \t]*[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+[ \t]*(?:=[ \t]*(?:[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22))?)*[ \t]*;[ \t]*rel[ \t]*=[ \t]*(?<rel>[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22)[ \t]*(?:[,;]|$)"
test_str = ("</test/11/webmention>;me; rel=\"webmention\"; pa=wow\n"
"</test/11/webmention>;me; rel=webmention; pa=wow\n"
"</test/11/webmention>;me; rel=\"webmention and more\"; pa=wow\n"
"</test/11/webmention>;me; rel=webmention, </test/11/webmention>;me; rel=webmention;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.