package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<(?<url>[^>]*)>(?:[ \t]*;[ \t]*[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+[ \t]*(?:=[ \t]*(?:[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22))?)*[ \t]*;[ \t]*rel[ \t]*=[ \t]*(?<rel>[\x21\x23-\x27\x2A\x2B\x2D\x2E\x5E-\x60\x7C\x7E\x30-\x39\x41-\x5A\x61-\x7A]+|\x22(?:[\x09\x20\x21\x23-\x5B\x5D-\x7E\x80-\xFF]|\x5C[\x09\x20\x21-\x7E\x80-\xFF])*\x22)[ \t]*(?:[,;]|$)`)
var str = `</test/11/webmention>;me; rel="webmention"; pa=wow
</test/11/webmention>;me; rel=webmention; pa=wow
</test/11/webmention>;me; rel="webmention and more"; pa=wow
</test/11/webmention>;me; rel=webmention, </test/11/webmention>;me; rel=webmention;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}