import re
regex = re.compile(r"<div>((?:(?!<div>).)*?)<\/div>", flags=re.MULTILINE)
test_str = ("<div> foo <div> bar </div>\n\n"
" <div> bar </div> baz </div>\n\n"
"<div> foo <div> bar </div> baz </div>\n\n"
"<div>< <span>Foo</span> ></div>\n"
"<div>< <span>Foo</span> v></div>\n"
"<div>< <span>Foo</span> iv></div>\n"
"<div>< <span>Foo</span> div></div>\n"
"<div>< <span>Foo</span> /div></div>\n"
"<div>< <span>Foo</span> </div></div>\n"
"<div><d <span>Foo</span> ></div>\n"
"<div><d <span>Foo</span> v></div>\n"
"<div><d <span>Foo</span> iv></div>\n"
"<div><d <span>Foo</span> div></div>\n"
"<div><d <span>Foo</span> /div></div>\n"
"<div><d <span>Foo</span> </div></div>\n"
"<div><di <span>Foo</span> ></div>\n"
"<div><di <span>Foo</span> v></div>\n"
"<div><di <span>Foo</span> iv></div>\n"
"<div><di <span>Foo</span> div></div>\n"
"<div><di <span>Foo</span> /div></div>\n"
"<div><di <span>Foo</span> </div></div>\n"
"<div><div <span>Foo</span> ></div>\n"
"<div><div <span>Foo</span> v></div>\n"
"<div><div <span>Foo</span> iv></div>\n"
"<div><div <span>Foo</span> div></div>\n"
"<div><div <span>Foo</span> /div></div>\n"
"<div><div <span>Foo</span> </div></div>\n"
"<div><div> <span>Foo</span> ></div>\n"
"<div><div> <span>Foo</span> v></div>\n"
"<div><div> <span>Foo</span> iv></div>\n"
"<div><div> <span>Foo</span> div></div>\n"
"<div><div> <span>Foo</span> /div></div>\n"
"<div><div> <span>Foo</span> </div></div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")