#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b([gG])onna\b"
Local $sString = "gonna" & @CRLF & _
"Going to"
Local $sSubst = "$1oing to"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)