$re = '/\b([gG])onna\b/m';
$str = 'gonna
Going to';
$subst = "$1oing to";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;