use strict;
my $str = 'gonna
Going to';
my $regex = qr/\b([gG])onna\b/mp;
my $subst = '$1oing to';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";