// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([gG])onna\b").unwrap();
let string = "gonna
Going to";
let substitution = "$1oing to";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}