// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([ \t]*)(.*?(?:[\u3000-\u303F]|[\u3040-\u309F]|[\u30A0-\u30FF]|[\uFF00-\uFFEF]|[\u4E00-\u9FAF]|[\u2605-\u2606]|[\u2190-\u2195]|\u203B).*?)([ \t]*)$").unwrap();
let string = "{
\"glossary\": {
\"title\": \"example glossary\",
cm=\"私は今プログラミングーをしています\";
\"text2\": \"example glossary\",
cm=\"私はABあああをしています\"
}";
let substitution = "$1/*$2*/$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}