#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\t ]*\* @priority[\t ]{1,}([a-zA-Z]{1,})"
Local $sString = "/**" & @CRLF & _
"* @param PlayerChatEvent $event" & @CRLF & _
"* @priority HIGH" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")