const regex = /^[\t ]*\* @priority[\t ]{1,}([a-zA-Z]{1,})/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\t ]*\\* @priority[\\t ]{1,}([a-zA-Z]{1,})', 'm')
const str = `/**
* @param PlayerChatEvent \$event
* @priority HIGH
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}