$re = '/^[\t ]*\* @priority[\t ]{1,}([a-zA-Z]{1,})/m';
$str = '/**
* @param PlayerChatEvent $event
* @priority HIGH
*/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);