re = /^[\t ]*\* @priority[\t ]{1,}([a-zA-Z]{1,})/m
str = '/**
* @param PlayerChatEvent $event
* @priority HIGH
*/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end