using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s).*?[.?!](?:\s.*?[.?!]){0,2}";
string substitution = @"$0\n";
string input = @"Sentence 1. Sentence 2? Sentence 3! Sentence 4. Sentence 5. Sentence 6. Sentence 7. Sentence 8. Sentence 9. Sentence 10.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}