re = /(?s).*?[.?!](?:\s.*?[.?!]){0,2}/
str = 'Sentence 1. Sentence 2? Sentence 3! Sentence 4. Sentence 5. Sentence 6. Sentence 7. Sentence 8. Sentence 9. Sentence 10.'
subst = '$0\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result