$re = '/(?s).*?[.?!](?:\s.*?[.?!]){0,2}/';
$str = 'Sentence 1. Sentence 2? Sentence 3! Sentence 4. Sentence 5. Sentence 6. Sentence 7. Sentence 8. Sentence 9. Sentence 10.';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;