const regex = /(?s).*?[.?!](?:\s.*?[.?!]){0,2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s).*?[.?!](?:\\s.*?[.?!]){0,2}', 'g')
const str = `Sentence 1. Sentence 2? Sentence 3! Sentence 4. Sentence 5. Sentence 6. Sentence 7. Sentence 8. Sentence 9. Sentence 10.`;
const subst = `$0\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);