import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][-a-zA-Z]*(?:\\s+[A-Z][-a-zA-Z]*)?";
final String string = "Madonna has a new album\n"
+ "Paul Young has no new album\n"
+ "Emmerson Lake-palmer is not here";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}