$re = '/^[A-Z][-a-zA-Z]*(?:\s+[A-Z][-a-zA-Z]*)?/m';
$str = 'Madonna has a new album
Paul Young has no new album
Emmerson Lake-palmer is not here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);