// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][-a-zA-Z]*(?:\s+[A-Z][-a-zA-Z]*)?").unwrap();
let string = "Madonna has a new album
Paul Young has no new album
Emmerson Lake-palmer is not here";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}