re = /^[A-Z][-a-zA-Z]*(?:\s+[A-Z][-a-zA-Z]*)?/m
str = 'Madonna has a new album
Paul Young has no new album
Emmerson Lake-palmer is not here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end