using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"S\[[^]]*\](*SKIP)(*FAIL)|\((?:[^()]|(?R))*\)";
string input = @"I am a (test) S[ but i am (not catched)], catch (me (if you (()(())) can))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}